ここ最近このブログで困った事が起きて悩まされている
咲月ミオです!

( ノ゚Д゚)こんばんわ

その困った事とはワードプレスの事です。



ワードプレスとは無料で使えるブログソフトですね。

現在このドメイン


「satukimio.biz」


には、

「satukimio.biz」部分にシリウスで作ったブログがあります。

そして!


そのドメインのすぐ下のディレクトリにあたる部分


「satukimio.biz/oekaki-zanmai/」


oekaki-zanmaiにワードプレスが入っています。
このディレクトリに入れたワードプレスで困った事がおきました。


ある日、このワードプレスにアクセスしたら


「サーバーのPHPバージョンは5.1.6ですが
WordPress3.5.1は5.2.4以降で利用可能です」


とかなんとか出てきてワードプレスが表示されない!!


Σ(゚д゚lll)ガーン

最初に気がついたのは、ワードプレス専用のブログ投稿ツール


「WordPressPost」というツールから投稿しようとした時に
エラーが出たこと。


はて?
なんで??

とりあえずブログにアクセスしてみたんですね。
そして表示されたのがさっきのメッセージ。


( ゚Д゚)ハァ?


とりあえずワードプレスのPHPのバージョンは
サーバーで切り替えることが出来ます。


私はXサーバーを使用しています。


ネットで調べてみました


「Xサーバー PHP バージョン 戻る」


で!
どうやらXサーバーでそういう事象があるらしい。

.htaccessというファイルが更新されてしまう事が原因。


ナニソレ?


それが何なのか詳しい話はともかく。
それが設定ファイルになってるらしい。


それが上書きで書き換えられることで発生するという。


とりあえず対処法をあれこれ検索。


自分は何もしてないのにその設定ファイルが
書き換えられているって事だよねー


q( ゚д゚)pブーブーブー


と、文句を言っても仕方がないので検索♪


Xサーバーの仕様で.htaccessを更新したり削除すると
PHPのバージョンがデフォルトに戻っちゃうらしい

やめてよーo(`ω´*)oプンスカプンスカ!!


と、文句を言いつつ頻繁に更新されるファイらしいので
毎回表示されなくなるのは困ります。

マジで(;・∀・)


調べてみた結果その.htaccessのファイルに
ある記述をするというのがありましたので


suPHP_ConfigPath /home/XXXXXXXX/YYYYYYYY.com/xserver_php/
AddHandler x-httpd-php5.3 .php .phps



これをコピペしてみる

ちなみに上の段のxxxxとかyyyの部分は自分の情報を入れます


xxxxxxには自分のサーバーIDを入れてみました
サーバーIDは契約した時にXサーバーから来るメールに
書いてありした。


YYYYYY.comの部分はそのときのドメインを入れました
今回の場合は


satukimio.biz を入れたんですよね。
さて。

これでPHPのバージョンの書き込みがなければいいんですけど
ちょっと様子を見てみます

また何かわかりましたらお知らせしますね


関連記事⇒